HeroEngine Forums

HeroEngine Support => General Discussion => Topic started by: PN-Dwight on Jan 17, 13, 12:10:33 PM

Title: [Responded] Water ripples move with Camera
Post by: PN-Dwight on Jan 17, 13, 12:10:33 PM
I recently discovered that with the latest Sapphire update, the water ripples move with the camera [before: they were static].

Is there something I missed?
Title: Re: Bug: Water ripples move with Camera
Post by: HE-Cooper on Jan 17, 13, 12:14:16 PM
There were a bunch of water and shader updates, so it's always possible something is happening that we didnt expect. What settings are you using so I can repro faster?
Title: Re: Bug: Water ripples move with Camera
Post by: StadiThompson on Jan 17, 13, 12:19:44 PM
It's the ocean and river setting, once you add the cubemap, the water's cubemap travels with the camera as you move.
Title: Re: Bug: Water ripples move with Camera
Post by: HE-Cooper on Jan 17, 13, 12:24:40 PM
Everything looks correct to me. Cube maps for river water were realigned to match Ocean water so they are both vertical now. But yes, a cube map means you're always inside of it. Trapped! :-)
Title: Re: Bug: Water ripples move with Camera
Post by: StadiThompson on Jan 17, 13, 12:29:19 PM
go into character mode and run along the coastline, sorry forgot that bit .
Title: Re: Bug: Water ripples move with Camera
Post by: HE-Cooper on Jan 17, 13, 12:42:27 PM
i suspect it's just an optical illusion with the reflected cube map traveling with you. If you set the wave speed high does the optical illusion go away?
Title: Re: Bug: Water ripples move with Camera
Post by: HE-Cooper on Jan 17, 13, 01:14:35 PM
I honestly can't tell if that's an optical illusion, or if it's the shader doing something weird, so I'll ask.

tracking horizontally along the cube map shows this behavior the most notably.

Title: Re: [Queued] Water ripples move with Camera
Post by: HE-HERB on Jan 21, 13, 11:02:22 AM
We've investigated this, and do not see an actual defect based on matching the pre-existing behavior.  Although, it's easy to see an optical illusion of incorrectness, or have it look "wrong" based on a bad cube map.

If there's a specific issue in your world, email us the specific repro information.  In the meantime, we're closing this

Cheers
Title: Re: [Responded] Water ripples move with Camera
Post by: keeperofstars on Jan 29, 13, 05:52:07 PM
I have the same problem as well. Was working perfectly fine before the package update, afterwards the water ripples all follow the characters movement.

It's possible it's something with our cubemap, but if that is the case we could use to know what causes the issue. So when making new cubemaps it's not created again. But as stated the cubemap looked fine before and didn't move with the characters movement.


Here is a link to video showing what we are talking about.

http://www.youtube.com/watch?v=1D8RfxOpl0g&feature=youtu.be (http://www.youtube.com/watch?v=1D8RfxOpl0g&feature=youtu.be)

Title: Re: [Responded] Water ripples move with Camera
Post by: HE-Cooper on Jan 29, 13, 06:30:27 PM
The issue is you wouldn't normally use animated waves and a static cube map, as it produces that optical illusion, but we have it queued up to look at after the next release to see if there's a medium to be found.
Title: Re: [Responded] Water ripples move with Camera
Post by: HE-Cooper on Jan 30, 13, 03:39:07 PM
Well, that didn't take long. Dave found the issue, shader fix, updated in the next package apply.
Title: Re: [Responded] Water ripples move with Camera
Post by: keeperofstars on Jan 31, 13, 09:30:48 PM
buy Dave a beer for us. :)

Thanks guys for the work.