HeroEngine Forums

HeroEngine Support => Art & Art Pipeline => Topic started by: gaarzen on Dec 08, 13, 06:37:11 AM

Title: [Resolved] Error: Rigid meshes not supported!
Post by: gaarzen on Dec 08, 13, 06:37:11 AM
Hey guys,
for some reason I'm receiving this error with one of my character parts:

!ERROR!System:Rigid meshes not supported!  Asset: character/male_character/hairs/male_hair01_head01.hgm, Mesh: Male_Hair01_Head0Shape1

Anyone might know what is the cause of this?

Thanks !  :)
Title: Re: Error: Rigid meshes not supported!
Post by: keeperofstars on Dec 08, 13, 09:49:55 AM
not being mean,

but Rigid Meshes are not supported.

Modeler has used a rigid mesh, in Male_hair_01_Head0Shape1
Title: Re: Error: Rigid meshes not supported!
Post by: gaarzen on Dec 08, 13, 09:56:24 AM
not being mean,

but Rigid Meshes are not supported.

Modeler has used a rigid mesh, in Male_hair_01_Head0Shape1
Well I'm the modeler :D and I haven't done anything differently with the hair mesh. It's a simple polygonal object bound with a smooth skin to the skeleton, just like all of the parts.
Title: Re: Error: Rigid meshes not supported!
Post by: gaarzen on Dec 08, 13, 01:25:54 PM
ok I found a solution :)
Apparently each part of the dynamic character has to be influenced by at least 2 joints and I had no idea that's the case. The hair mesh was influenced by one joint which was the primary head joint.
It took me quite some time to find but I found a small note to the subject in one of BENNETT's messages.