HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - GlorianLanTarini

Pages: [1] 2 3 ... 10
1
General Discussion / Re: Login error
« on: Jan 09, 18, 06:10:50 PM »
Checked and confirmed.

Thank you.

2
General Discussion / Re: Login error
« on: Jan 09, 18, 03:59:16 AM »
Hello again.

The situation is changed. No more error at login. But, my world now is "Down".

3
General Discussion / Re: Login error
« on: Jan 05, 18, 04:01:04 AM »
Hello Sarrene.

I rechecked this right now and, yes, error still here. But my "backdoor" - click on Cancel - still work too, so it doesn't disturb me much.

4
General Discussion / Re: Login error
« on: Jan 05, 18, 03:14:13 AM »
Thazager isn't only one. I got this error too. Right after subscription renew.
And I flush DNS. Nothing changes.

Also, I can say some more information:
If I click on cancel button in Launcher Update Utility after it reports about "Unable to connect to server" - I got the error "Socket operation on non-socket: Line=476" and HeroBlade start after that as usual and working fine.

PS: Server APAC 4

5
General Discussion / Re: player.ini
« on: Oct 07, 17, 01:16:38 AM »
Hello, Scott.
How about this algorithm?

  • The client checks LRC for settings.
  • If settings exist - load and apply them, else call server.
  • Server check for user settings backup in system area which stores all users settings backups.
  • If sys_area has the backup - return it to the client, else - return None.
  • If the client received backup node - restore settings in LRC and apply them. If the client received None - this is first (or clean) installation - create settings from scratch, and set them to default values.
  • Send settings changes to the server for storing in sys_area every time when client apply new settings.

It is simple and effective. And I use something very similar for user language settings. Only, I don't call to the server if it can't find LRC settings, but take user OS language as default.

By the way, this algorithm allows the user to use same settings on different computers. And you can decide which settings are hardware-independent, and which are not. Excellent for key binding and player's macros (if you allow it).

6
General Discussion / Re: Hero blade unknown
« on: Jul 28, 17, 10:56:42 PM »
Hmmm... Try to paraphrase your question? Because it is very fuzzy now.

To get heroblade you should download the installer from account page and install it. And nothing more, usually.

7
Well, that was easier than I thought.
I found out after some investigations that the account is loaded properly, the player connection creates and game session starts.

The last method which called by the engine is $ACCOUNT._SessionStarted( theAccount as NodeRef ).
Accordingly, the best place to implements the game mechanics is method HE_PostSessionStarted( theAccount as NodeRef ).

8
I am not sure exactly what you did to "disable" CSS.

Code: [Select]
method HE_CSSEnabled( enabled references Boolean ) as Boolean
// Globally enabled/disable the CSS system
 
// To disable the CSS system:
  enabled = false
  return true
.

9
Hello, everybody.

Today I decided to disable CSS in my game world because I don't need to choose a character in my design.
Of course, login process stops on area 1 for now.

But, before I start to implement game-specific mechanic, I need to know - what exactly I should do.

I mean - what already done at the moment when login process find that CSS disabled and stopped?
Was player connection factored? Was account root node loaded? Was session started? Etc.

I will be glad to any help, but especially qualified ones (I need to be sure).

10
Hi, Prometheus.

There are several ways to achieve the result you needed.

First:
Create fullscreen Virtual Stage GUI, with lab and character, which will show at selection area.

Second:
Push and activate "Camera layer" on entering to CSS area (basically, it hasn't it), then create and activate the camera. After that, go to the editable instance of CSS area and create a lab. Then use "character outfit system" to show character.

Both ways are very complex and require much time and knowledge.

Write if you need additional help.

To Thazager:

What you write is part of the "character outfit system". It works not trivial. It took me a full day just to trace all of the scripts involved in this process.

11
General Discussion / Re: [NOT resolved] Heroblade: login failed
« on: May 30, 17, 09:35:05 AM »
Greetings, Bardaf.

In this kind of situation, you should send a message to support@heroengine.com

Login issues are rare but they happens, and only support can help you with it.


12
+1
Me too.

13
Scripting & Programming / Re: combat stance
« on: May 20, 17, 01:14:50 AM »
Hi, Thazager.

Basic _playerCharacter class don't using E_CommonCharacter class as parent, but only _commonCharacter. So, you should check - has your_playerCharacter class E_commonCharacter as parent or not? I know it's sound very silly, but sometimes this sort of things get lost from view.

14
Scripting & Programming / Re: Area loading question
« on: Mar 04, 17, 09:04:12 AM »
I have just ignored this error since it still seems to travel anyways. It happens on the first request to travel to a new area.

Is this mean this error is common and reproducible?
If so - maybe engine's team should check out it? Or, maybe there is advice how to avoid it?

I feel it's all about time. Because while testing, I got situation when travel call was made many times with short time intervals. Five calls to be accurate. And I got four errors. Fifth time was successful.

15
Scripting & Programming / Re: Area loading question
« on: Mar 02, 17, 05:25:19 AM »
possible edge case:

If the area doesnt launch then the matchmaking system will never know, make a timer in the matchmaking system to drop players from loading if the area doesnt respond after X seconds


Thanks, I don't thinking about it. Will have to doing something out about that.


Recent tests of the discussed design showed a good result - everything works as it should. But, I'm a little confused - when I initiate the creation of a new combat arena, the system reports the following error:

Quote
[Travel Failure Recovery] SCRIPT ERROR: TravelFailure for 9223372059369021589 area:9223372061780021595 inst: 3 reason:Travel failed unexpectedly while moving 9223372059369021589 to area 9223372061780021595, 3

but then, players traveling without problems to the area that was launched. I have the feeling that something in one of the scripts tries to send the players to the area before it is loaded. But, I checked all my scripts and have not found such attempts. Could something in clean engine do this?

Pages: [1] 2 3 ... 10