HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - elchettoloco

Pages: [1] 2
1
Scripting & Programming / Re: Quest System Design
« on: Jul 27, 12, 01:39:31 PM »
Daily Quests?  ;D

2
Developer Created Tutorials / Re: SpecOracle Step-by-Step issue
« on: Apr 27, 12, 05:59:12 PM »
GFG thank you so much!  This should be on the wiki! 

Greatly appreciated :) my spec problems are no longer  8)

In step 3 I cant access the link because it no longer exists or is off limits

EDIT: Not sure what heppened but now I can access it.  Thanks again!

3
Developer Created Tutorials / Re: SpecOracle Step-by-Step issue
« on: Apr 22, 12, 05:56:52 PM »
Thanks Song!  I did find out where I got stuck and I think I just skipped it after thinking of banging my head against a pillow.

Its where you're supposed to add this bit of HSL code to the spec list(Step-By-Step Guide)

var oracle = GetPrototype("YourSpecOracle")
where oracle is kindof YourSpecOracle
  oracle.AddCollectionHeader("<fieldname>","<displayname>",<true|false>)
.

I didn't see any particular classmethodsscript and/or method where I implement that.

Thanks again.

4
Developer Created Tutorials / Re: SpecOracle Step-by-Step issue
« on: Apr 19, 12, 08:51:46 PM »
First I would like to thank you all for the helpful replies!  I did like GFG's walkthru much better.  I was able to add my spec oracle via the GUI editor, but upon rebuilding the utilities interface I don't see my Inventory spec oracle :(

Is there something that I am missing?  Looks that way ???

Thanks

5
Hello all!

I been following thru with the SpecOracle step tutorial and it went smoothly to a point. 

On step 13 I guess Im a bit confused with the implementation(s).  Are the implementation(s) done in the _SpecOracleUtilsClassMethods script or the game specific?

Also I am wondering how to add my new spec with the GUI editor.  Apparently, I'm not seeing this clearly.  Im sure there are steps that need to be taken in orfder to finish this, but just can't quite get it together.

Any help is greatly appreciated,
Thanks ;D


6
Scripting & Programming / Re: Question about Spec Oracles
« on: Apr 13, 12, 02:14:00 PM »
Quote
or editing table to work with the data can be accessed through the console:
/heoracle open <specoraclename>
example:
/heoracle open _fxspecoracle

tried that and the console returned an unknown command error.  I have a few questions of my own about creating a new spec seeing as this is where I've finally chosen to start.  I'll post them soon.

Thanks  8)



7
Developer Created Tutorials / Re: Simple mana system
« on: Mar 04, 12, 11:10:55 PM »
Great Tutorial Judge!  All worked perfectly

I did implement the mana gauge on the status bar, however, when using the fireball ability the gauge does not move(it is at the default setting).  I'm taking it there is some association regarding this and I did check the xml and properties and did not find anything that tied the healthPanel and/or slider to any particular script.

Or perhaps I missed it.

Thanks anyway m8!

8
Quote
Surely you aren't a n00b.
Maybe a Newb. But not a n00b. Atleast I hope not  ;)

Hahah!

Well this is lame.  I thought it was over and now this.  Anyone having trouble getting the GameNewsEditor XML to the repository?  I've recompiled it quite a few times and its still not showing up.

I tried to create it in the organizer but it says the GameNewsEditor XML already exists.  This is wahts stopping me from being able to add/update the news.

Is there anything else for me to try?

Thanks,

Edit: Okay so I did check the file repository and it is there so I don't know what to do at this point.  All my other XML is getting into the repository and showing up in the organizer.  Just not this particular one :(

9
thanks again Jrome.  Thats what I was thinking, but didnt know the call bc im kinda a n00b  :-\

However, I am starting to pick this up now that I actually have the idea now on how things are structured.

Keep up the good work man!

10
lol yea thanks Jrome!  I just tried that myself and everything now works fine.  Last question.  IF we do not have a custom utilities set up yet, how would one go about getting to the game news browser for testing?

Thanks,
 ;D

11
don't quite remember if I did that or not cal, but I didn't see the obsSubject in the server news class when I checked it.  But what if I didn't at the time I was doing the tutorial?

12
Developer Created Tutorials / Re: Press "I" to open a gui window
« on: Feb 17, 12, 08:35:10 PM »
Excellent.  Worked perfectly! 

Thanks Jrome!  ;D

13
The tutorial has been going smoothly for me up to one point.  In the NewsWindowClassMethods script I get a script error

"The listener node must implement "EventRaised" method.

when I look in that script I do see the implementation

method EventRaised( obs as NodeRef of Class ObsSubject, data as NodeRef )
  where data is kindof eventObject
    #if debug
    println("EventRaised: " + data.eventType)
    #endif
    when data.eventType
      is "NEWSUPDATE"
        me.NewsWindow_Populate()
      .
    .
  .
.

according to the scripterror the problem ocurrs at line 19(for me) in the script: $News.addListener(c)

I even tried a complete copy/paste of jromes code and still got the error thrown out at me.

Is there something I need to change?

Thanks for the help :)

14
Quote
No problem. Anything to help the community, as long as it is within my limited knowledge.
I would like to do more. But, I can't think of anything right now.

Well I am having a bit of an issue with my reply command.  The text that tells you the format of it works but the reply itself isn't getting to the recieving player :/

and grouping as well.  I am starting to finally get my arms around this but just keep running into little stuff thats slowing me down.

Thanks again  ;)

15
Thanks Madz,

Its working now.  Lol now just to get the chat window to become visible.  Haha

Thanks

Alrighty!  Seems that I didn't add the prototype(noob move).  Once I saved and added it I had to restart blade but it has been working fine ever since!

Thanks Jrome for the awsome tut!

Pages: [1] 2