HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Irushian

Pages: [1]
1
General Discussion / Scrollbar issue when resizing a cell
« on: May 07, 15, 06:01:05 PM »
I've created a sortablecollection with a scrollbar, I have the header predefined in the gui so it's not created via HSL. I've noticed that when doing this the cell height defaults to 20, if I create the header via HSL then it resizes the cell to what the correct height should be for my content however I lose the scrollbar.

So, I attempted to get around this, and I called _recalculateAllCollectionRowsHeight() on the GUI, this resized the cells to the correct height but again caused the scrollbar to vanish. So finally I attempted manually setting the cell height just incase something under the hood was being called that I had not yet noticed, I did this via:

Code: [Select]
   ClientArea as NodeRef of Class GUIControl = FindGUIcontrolByName( me, "Container.sortableCollection.clientarea" )
   foreach Child in ClientArea.children
      child.size.y = 28
   .

Again, the cells height changed to what I wanted it to be and again, the scrollbar vanishes.

I'm stumped and about finished for the night, so I figured best to post this on here and hopefully someone can point me in the right direction when I return in the morning before work, or note if in the unlikely event that this is a bug.

Thanks in advance!

2
_getNodePropetyEditorCellFieldName

It's missing the 'r' from property.

3
Scripting & Programming / Exit water choppiness.
« on: Apr 13, 14, 03:05:53 PM »
The videos will show better than I can describe, the first one will show how it is when you move out of the water yourself, and the second video is watching another character stand right on the edge of the water.

Has anyone encountered anything like this within their own worlds?

https://www.youtube.com/watch?v=JxCoTuZM0cI
https://www.youtube.com/watch?v=WCW1p-Qo5PY

4
Scripting & Programming / [Resolved] _ChatSystemArea
« on: Jan 08, 13, 10:51:47 AM »
I updated to the latest version this afternoon, and upon logging in I was literally spammed with the below every second.

As the servers have now gone down for the sapphire update I figured I'd post this up on here and see if anyone else has had this and what the cause was for them, which may hopefully shave a little bit of time looking for the culprit when the servers are back up.

Code: [Select]
[hsl_error] 9223372057091033625,0: [_ChatSystemArea] SCRIPT ERROR: Node 0 not found to call method CREATEFROMSPEC
01/08/2013 16:41:22 UTC
Call trace:
  Script _ChatHandlerClassMethods line 427 me[9223372057100021545]
  Script _ChatSystemCommandSubscribeClassMethods line 17 me[id=9223372057100021560 class=_ChatSystemCommandSubscribe]
  Script _ChatHandlerClassMethods line 349 me[9223372057100021545]
starting method/function _CHATCOMMANDQUEUETIMER_TICK
starting me[id=9223372057100021545 class=_ChatHandler]
[hsl_error] 9223372057091033625,0: [_ChatSystemArea] SCRIPT ERROR: Node 0 not found to call method CREATEFROMSPEC

5
Code: [Select]
18:36:59: !ERROR!HeroScript::HeroMachine::ScriptError:GOM::getVariableReferenceFromNode (10757): requested node ID (0) not found
18:36:59: !ERROR!System:SCRIPT ERROR: GOM::getVariableReferenceFromNode (10757): requested node ID (0) not found
08/24/2012 18:36:54
Call trace:
  Script Input_Movement line 218 me[9223372056150021549]
  Script Input_Movement line 148 me[9223372056150021549]
starting method/function ONCMDSTOP
starting me[id=9223372056150021549 class=E_playerAccount,HBNode,CharacterNode,_ACCControllerOwner]
18:38:12: System:SCRIPT[Input_Movement]:onCmdStart: LeftButton
18:38:12: System:SCRIPT[Input_Movement]:[Input_Movement] onCmdStart() - LeftButton.
18:38:12: System:SCRIPT[Input_Movement]:onCmdStop: LeftButton
18:38:12: System:SCRIPT[Input_Movement]:[Input_Movement] onCmdStart() - LeftButton.
18:38:15: !ERROR!System:GUIXMLChomper::ChompSet prototype not found: HE_ControlPanelClassAddRemovePanel.ClassList.movePanel

I'm not exactly sure what has caused this, the only change that I have done (and I believe, also reversed) was to the E_ACCControllerClassMethods file. Earlier when I was playing around it was all working fine and as just stated, all changes i've added have been reversed to when it was working prior to this (to the best of my memory, they were only tiny changes anyhow).

The last line about the ChompSet is also new, I've never had that come up nor have I removed anything. I have had my world up and logged this afternoon, just haven't done much (doubt there would be any cause from this, but just figured I should note as much as possible).

Line 148: FigureOutMovement()
Line 218: if char.E_isDead

So as you can see, these lines are stock code, as well as the variable getters.

Any help would be much appreciated, especially as it doesn't let me load into the world currently.

Edit: I figured I should also mention the big red square in the top left of the screen when it fails to load.

Pages: [1]