HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - TGSRofar

Pages: [1] 2 3 ... 10
1
General Discussion / Re: Interference?
« on: Dec 08, 17, 05:43:53 PM »
There are no interactions between visual studio and HeroBlade so you won't see any issues with this.

2
Developer Hero Projects / Re: The Repopulation Update 2017/09/24
« on: Sep 25, 17, 04:04:31 PM »
Technically, it wasn't script versioning.  It was spec versioning.

3
Scripting & Programming / Re: any difference in script?
« on: Jun 06, 17, 03:57:29 PM »
Thanks Scott.  I have been quiet for quite some time but have been lurking in the background throughout.

4
Scripting & Programming / Re: any difference in script?
« on: Jun 05, 17, 03:56:38 PM »
Unofficially speaking, I can't imagine there is a difference in execution.

5
General Discussion / Re: Hero Engine Evolution
« on: Oct 21, 15, 04:12:25 PM »
Nice editorial with a lot of good points being made.

6
I would guess that 1/2 is being interpreted as dividing an integer by an integer.  This may then cast the result to a float since your variable is declared as float.  Try 1.0f/2.0f and see if that results in 0.5 being printed out.

7
GUI Creation / Re: Get rid of error?
« on: Jun 23, 14, 04:06:44 PM »
In the script editor, you should be able to open the file that is a list of the gui xml files.  File name is guixml.lst.  Try removing the entry from that file.  This may resolve it.

8
Design & World Building / Re: Re: occlusion culls and frame rate
« on: Feb 24, 14, 04:49:25 PM »
IE explorer doesn't like to show the reply tray,

unless you run in compatibility mode.

Thanks for that tip.  Now, whenever I want to reply I won't have to play the "guess where to click" game.

9
You say one never gets a response when the spec is requested.  Is this when creating a new spec or is this when requesting one that has been created already?  If it's the first situation, make sure you created your oracle prototype. 

10
Art & Art Pipeline / Re: Software list
« on: Feb 12, 14, 07:45:25 PM »
Paint.NET - I use this for 95% of all my image work.  I keep Gimp around for the other 5%.

11
Scripting & Programming / Re: Deleting fields from classes?
« on: Jan 22, 14, 04:27:01 PM »
You have a field that is based on the class you are trying to remove a field from.  First, you must delete the field that is based on your afInventoryItem class.  Then you can modify that class and re-create the field you deleted.  Of course, if you are using the other field in another class then you can't delete it until you remove it from that class.

I have gotten myself in situations before where I had to do a lot of unwinding to get to the point I could remove a field.  It's not fun.

12
Scripting & Programming / Re: Social System
« on: Dec 24, 13, 08:41:09 AM »
Really confused here about the _SocialNodePoolArbiter and the _SocialQueueNodePool management.

When _RequestSocialQueueNodeForType is called on the Arbiter for the first time for a given social_queue_type, a call is made to _RegisterAndInitQueueNodeTypeWithPools for the given type with a batch size of 10 and a low limit of 5.  This results in 10 queue nodes in the _socialSysQueueOpenNodeList all with a state of _Idle.

The next thing that happens is a call to _GetOpenSocialQueueNode on the node pool.  This is where the confusion comes in.  This method checks to see if the _socialSysQueueOpenNodeList count is greater or equal to the low limit..which it will be because 10 nodes were created and added to that list and the low limit is 5.  Since the count is greater than or equal to 5, it moves all the nodes into the _socialSysQueueClosedNodeList and changes state to _InUse.  The returned node is the last one in the list.

The next time a call is made to _RequestSocialQueueNodeForType, it doesn't call _RegisterAndInitQueueNodeTypeWithPools since that node pool type already exists. However, it does call _GetOpenSocialQueueNode which finds no open nodes (because they are all in the closed list now) so it creates 10 more in the open list and subsequently moves them to the closed list. 

Every time _RequestSocialQueueNodeForType is called this will happen.  Every time it will create 10 more nodes and then just move them to the closed list.  The only one of the 10 that is ever used is the 10th one.

Is something wrong with the code or am I just completely missing something about how this is supposed to work?

13
Scripting & Programming / Re: Social System
« on: Oct 06, 13, 06:15:56 AM »
I appreciate the time you took to provide the details on how you implemented this Scott.  This is very helpful.

Quote
*This is probably not the best approach for storing request data, to simply have one set of fields, since there could theoretically come many requests from many different players at once each of which would overwrite the data of the previous request.

I decided to handle this by creating a request class with the fields.  A node for this request class gets created and has a method to handle _RecieveRequestedSocialDataOwnerCharacterID().  Then it calls back to the socialsystem node passing itself as a parameter.  The socialsystem node destroys the request node when it has processed it.

14
Developer Introductions / Re: Hello from the Scarlet Thread
« on: Aug 25, 13, 06:53:03 PM »
Welcome to Hero Scarlet.

I liked what I saw of your work in the other community. Looking forward to see how your game comes to life here.

15
Nice video.  I'm interested to see how it works out for you. Time will tell.

Pages: [1] 2 3 ... 10