HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Resolved] Shadows not casting indoors  (Read 1159 times)

Stadi_Thompson

  • General Accounts
  • *
  • Posts: 324
    • View Profile
[Resolved] Shadows not casting indoors
« on: Jan 01, 11, 04:26:31 PM »

We have a series of models which are mesh interior rooms, once imported shadows from omni lights and spot lights do not cast shadows no matter what settings are enabled in the render panel.
« Last Edit: Oct 31, 12, 04:06:43 PM by HE-Cooper »
Logged

HE-CHRISTOPHER

  • HeroEngine
  • *****
  • Posts: 424
    • View Profile
Re: Shadows not casting indoors
« Reply #1 on: Jan 03, 11, 08:37:11 AM »


Light nodes (omni or spot) do not cast shadows due to the rendering costs, so this is functioning as expected.
Logged
Christopher Larsen
CTO
HeroEngine

Stadi_Thompson

  • General Accounts
  • *
  • Posts: 324
    • View Profile
Re: Shadows not casting indoors
« Reply #2 on: Jan 03, 11, 01:23:24 PM »

Thanks Christopher. I found a workaround for anyone interested in having indoor shadows. You can use a dynamic sky and set the room to not cast dynamic shadows in the properties panel. It will result in the shadows casting from the objects in the room and also onto the floor. To get a little more accuracy you can optionally separate the room, example make the ceiling a separate object (disable shadow casting from the ceiling) if you want the walls to cast shadows (useful if you have pillars attached to the wall and want them to cast also). You most likely will have to tweak the sun settings and time to mimic indoor lighting. I recommend using 3 point lighting and make the side light close to black to darken shadows. in theory I would guess you make the room/level its own zone and disable time in that zone.
« Last Edit: Jan 03, 11, 01:25:29 PM by info360covers »
Logged