HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Resolved] Having troubles with character movement.  (Read 2692 times)

DarkOm3n

  • General Accounts
  • *
  • Posts: 16
    • View Profile
    • Drive
[Resolved] Having troubles with character movement.
« on: Mar 04, 12, 11:39:33 AM »

I recently implemented new characters. Currently when I create a new character to get the new style of the avatar I cannot move.  I have the ability to turn the avatar, not forward or reverse movement. I worked out all the errors and a stack I had after initial implementation.

All i get for any form of output atm is
Code: [Select]
System:SCRIPT[_InputHandlerClassMethods]:_OnKeyBindingsLoaded: , /heroenginekeybindings.ini
System:SCRIPT[_InputHandlerClassMethods]:_OnKeyBindingsLoaded: , /gamekeybindings.ini
System:SCRIPT[_characterSelectionClassMethods]:Got updated names...
System:SCRIPT[E_ExperienceBarClassMethods]:xp: 0
System:SCRIPT[E_ExperienceBarClassMethods]:last: 0

There are no more ScriptErrors either.

Im not sure what other information may be required and apologize if i missed a post on how to format posts of these nature, any help/insight would be appreciated.

Has anyone encountered this and have an idea of where to look?
« Last Edit: Oct 22, 12, 09:06:29 PM by HE-Cooper »
Logged
If all else fails rm -rf /*

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Having troubles with character movement.
« Reply #1 on: Mar 04, 12, 12:15:24 PM »

The PC character controller is more complicated than NPC, so is sometimes easier to debug if you just setup a simpler test case, but anyways.

Open the animation panel, select your character, and force behaviors onto it (read the animation panel wiki) and if your chacater runs then its a character controller problem in script. If he doesn't, then it's a file setup problem. Either animations or the ass asq dat.

You have an error for a missing monkey toc dat, which means someone moved or deleted that file from the repository without removing the references in game, so that leads me to believe any number of other errors coulda be happening.

If you don't have any errors in the chat panel or the console panel then I would,

View the animations on the correct skeleton in the hero viewer, and then review the animation file setups to make sure they match the default character's. Did you ensure you actually translated the SRB movement within the animation file?
Logged

DarkOm3n

  • General Accounts
  • *
  • Posts: 16
    • View Profile
    • Drive
Re: Having troubles with character movement.
« Reply #2 on: Mar 04, 12, 12:20:20 PM »

AH, you caught the monkeytok heh. It was from a previous test and the folder where the issue is caused should be removed. So if there is an animation error it will stop character movement? Will be easy enough to fix if so, i was under the impression that animation had no effect on the actual movement though.

Thanks for a prompt reply as well HE-Cooper, good to be back on the engine. :)
Logged
If all else fails rm -rf /*

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Having troubles with character movement.
« Reply #3 on: Mar 04, 12, 12:41:48 PM »

Make sure you read up on player character movement. If you don't believe animation has any effect on character movement, then I've found your problem. :-)

You need to animate your character movement animation with the translation distance that you want the character to traverse in game. You could wire up walk/run blend behaviors and rewrite the character controller to do anything you'd like, but for out of the box SRB movement in the animation is how the engine translates the character.
Logged

DarkOm3n

  • General Accounts
  • *
  • Posts: 16
    • View Profile
    • Drive
Re: Having troubles with character movement.
« Reply #4 on: Mar 04, 12, 02:14:05 PM »

Thanks alot HE-Cooper!... I feel somewhat stupid yet enlightened and now understand the relation a little more. Thank you for setting me straight. :)
Logged
If all else fails rm -rf /*

DarkOMEN

  • General Accounts
  • *
  • Posts: 16
    • View Profile
Re: Having troubles with character movement.
« Reply #5 on: Mar 11, 12, 08:57:54 AM »

I found this thread very enligtening.  Posting the wiki page appropriate to this behaviour.

http://hewiki.heroengine.com/wiki/Character_Animation_Movement
Logged