HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Resolved] Help with static character export/instancing  (Read 3060 times)

SmeTheWiz

  • World Owners
  • ****
  • Posts: 4
    • View Profile

Hello,
I recently purchased a license for HeroEngine (1-2 weeks ago) for a hobby game. I've read through all of the wiki articles and many forum pages to get familiar with the engine. I  would be grateful if anyone could help me, or point me in the right direction.
I've created a basic character (static) and would like just to view it in the engine. It has just a basic idle animation (30 frames) and I have uploaded it through the repository browser. I can create the model in game by just going to the create tab, and have been able to use the chat window to add the spec for the character, but when trying to spawn an instance of the character, it looks to be successful in the window, but nothing is visible.
Also I can view the character in the hero viewer and load the animation and textures just fine.
Any help would be great!
Thanks,
Ean
« Last Edit: Oct 26, 12, 02:38:47 PM by HE-Cooper »
Logged

SmeTheWiz

  • World Owners
  • ****
  • Posts: 4
    • View Profile
Re: Help with static character export/instancing
« Reply #1 on: May 15, 12, 04:15:05 PM »

To add more updated info:
After trying to posses the character the chat window displays the following message

Quote
[hsl_error] 9223372055806651638,0: [ZackTestArea] SCRIPT ERROR: In function ScriptError: Child classes must override the abstract parent class _AiState's _EnterAiState.
05/15/2012 21:14:09 UTC
Call trace:
Script _AiStateClassMethods line 5 me[id=9223372055982651732 class=_AiStateControlledByOther]
Script _AiAgentClassMethods line 41 me[id=9223372055982651664 class=E_nonPlayerCharacter,E_AiAgent]
Script _AiAgentClassMethods line 541 me[9223372055982651664]
Script _nonPlayerCharacterClassMethods line 135 me[9223372055982651664]
Script _npcClassMethods line 820 me[id=9223372055982651631 class=_npc,E_NPC]
Script _npcClassMethods line 45 me[9223372055982651657]
Script _CommandHandlerClassMethods line 32 me[9223372055982651657]
starting method/function _PROCESSCOMMAND
starting me[id=9223372055982651657 class=_CommandHandler]

Again, any help on this would be great
Thanks
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Help with static character export/instancing
« Reply #2 on: May 16, 12, 08:03:23 AM »

Hi Mr. Sme, have you looked in the console window for errors?  Character not showing could be any number of issues, but pretty much all of them throw some sort of error into the console.  The script error is probably just a symptom of the issue, not the cause.
Logged

SmeTheWiz

  • World Owners
  • ****
  • Posts: 4
    • View Profile
Re: Help with static character export/instancing
« Reply #3 on: May 16, 12, 10:59:55 AM »

Thank you for the reply, I wasn't aware of the errors being different from the console and chat (I'm very new)

here's what the console says when trying to load the world:
Quote
12:11:52: !ERROR!System:Input [BasePosture] does not have enum handle [Alive]!
12:11:52: !ERROR!System:BehaviorBase: Attempt to set input [BasePosture] to [Alive] failed, enum not valid for this input (node=9223372055999651687).

any ideas?
« Last Edit: May 16, 12, 11:10:53 AM by SmeTheWiz »
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Help with static character export/instancing
« Reply #4 on: May 16, 12, 11:33:21 AM »

Hmm, well sounds like you've modified the inputs in your AAS file.  That error comes from the ACCC (the script character controller) trying to set the BasePosture input to an enum value (Alive) that isn't defined in the AAS.

Are you using Max or Maya?
Logged

SmeTheWiz

  • World Owners
  • ****
  • Posts: 4
    • View Profile
Re: Help with static character export/instancing
« Reply #5 on: May 16, 12, 11:41:40 AM »

Thanks again for the replies, we got everything working just about 5 minutes ago  :-[
there were errors in the aas.
-Ean
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Help with static character export/instancing
« Reply #6 on: May 16, 12, 11:43:11 AM »

Ah, thought so!  Don't be embarrassed, you're learning :)
Logged