HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Resolved] Bip01 won't move on Y  (Read 5239 times)

grogbro

  • World Owners
  • ****
  • Posts: 117
  • ZOMBIES! YAY! RUN!!
    • View Profile
    • My Portfolio
[Resolved] Bip01 won't move on Y
« on: Sep 26, 12, 10:36:59 PM »

I am not typically an animator with Max so I am not sure if something is locked with the Bip01 preventing it from moving on the Y axis. I can move it up and down on the Z but for my walk it won't move (and the srb then doesnt move). When I put the rig into Figure Mode it moves fine on the Y, but not out of Figure mode for animating.

For the character I am using one of the example rigs found in this folder with the HEExampleArt:
\HEExampleArt\_HE_example_art\3dsMax\character sample

File: character_sample_dynamic.max

I am hoping there are just Locks I am missing. Any help would be greatly appreciated.

« Last Edit: Sep 27, 12, 06:57:53 PM by grogbro »
Logged

Stadi_Thompson

  • General Accounts
  • *
  • Posts: 324
    • View Profile
Re: Bip01 won't move on Y
« Reply #1 on: Sep 27, 12, 10:05:42 AM »

This is not a Hero Max file issue. It is how Biped work in 3ds MAX. DO NOT ANIMATE IN FIGURE MODE, figure mode is your bind pose. To move on the Y axis outside of figure mode to you must click this button

Edit: Sorry it's the button next to the red circle, my bad :)
« Last Edit: Sep 27, 12, 10:11:45 AM by Stadi_Thompson »
Logged

grogbro

  • World Owners
  • ****
  • Posts: 117
  • ZOMBIES! YAY! RUN!!
    • View Profile
    • My Portfolio
Re: Bip01 won't move on Y
« Reply #2 on: Sep 27, 12, 10:14:56 AM »

Sorry, maybe that wasn't the best explaination of my experience with Max. I have been using max for over 12 years, and animating with it but I have not been officially trained as an animator.

That's normally a common mistake with the axis controls you mentioned, but that is not the issue. Yes, it's not in figure mode, I talked about that in the post.

Bip01 will just not move on the Y, so it might be an update for max2012 I need or just the rig.

grogbro

  • World Owners
  • ****
  • Posts: 117
  • ZOMBIES! YAY! RUN!!
    • View Profile
    • My Portfolio
Re: Bip01 won't move on Y
« Reply #3 on: Sep 27, 12, 06:57:09 PM »

Here we go. If you can't move your Bip01, using 3dsMax. Go to the Motion tab, and turn off/un-highlight the 'In Place Mode'. I've never actually used it before but with some fiddling around I accidentally clicked it off and....WEEE!!!

In Place Mode is found under the Motions tab, then click +Modes and Display

« Last Edit: Sep 28, 12, 07:14:38 PM by grogbro »
Logged

Stadi_Thompson

  • General Accounts
  • *
  • Posts: 324
    • View Profile
Re: [Resolved] Bip01 won't move on Y
« Reply #4 on: Oct 04, 12, 10:20:01 AM »

Yeah that is a different sample character from what I downloaded years ago, haha. Should have checked it out before posting. In place mode is great for looping things that move forward, but a nightmare if on and not knowing haha. Glad you figured it out, Hero Devs may want to disable that in the sample as it is disabled by default when creating bipeds.
Logged