HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: $ALERT._ConfirmDialog and Invalid script "*None*"  (Read 844 times)

Grogard

  • World Owners
  • ****
  • Posts: 36
    • View Profile
$ALERT._ConfirmDialog and Invalid script "*None*"
« on: Jan 07, 13, 07:10:38 AM »

Hello. I have the next code when I click the button:
Code: [Select]
is "btnLogout"
      confirm as NodeRef of Class _ConfirmDialog = $ALERT._ConfirmDialog("confirmExit", "Выход", "Выйти из игры?")
      confirm._confirmDialogOwner = me
      args.handled = true
    .

And havwe the method on this GUI class:
Code: [Select]
method HE_ConfirmDialogAccepted()
  SendCommand( "/exit" )
.

method HE_ConfirmDialogDeclined()
  // Nothing to do here but let the dialog close.
.

But the i click any button i get this message in Error console:
Code: [Select]
!ERROR!System:GUIXMLChomper::ChompControlAttributeDynamicly: Invalid script "*None*". Field "_confirmdialogreturnscript" Prototype "_confirmDialog"

So what i do wrong?
Logged

cloudnine

  • General Accounts
  • *
  • Posts: 80
    • View Profile
    • Youtube
Re: $ALERT._ConfirmDialog and Invalid script "*None*"
« Reply #1 on: Jan 07, 13, 08:00:49 AM »

I had invalid script *none* come up before,
I just opened the xml and removed   script="*none*"
Logged

Grogard

  • World Owners
  • ****
  • Posts: 36
    • View Profile
Re: $ALERT._ConfirmDialog and Invalid script "*None*"
« Reply #2 on: Jan 07, 13, 08:12:52 AM »

Hm.
It's look like hack. DOn't want to use hack (
Logged