HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: Agent already in combat state - So NPC don't attack me  (Read 575 times)

Grogard

  • World Owners
  • ****
  • Posts: 36
    • View Profile
Agent already in combat state - So NPC don't attack me
« on: Jan 23, 13, 03:34:05 AM »

Hello.

I was added new NPC monkey to hte my test location. But the added don't wont to attacke me.

They are always in the combat state. And don't atack me $(

In What maybe the problem?
Logged

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Agent already in combat state - So NPC don't attack me
« Reply #1 on: Jan 23, 13, 10:31:26 AM »

The example combat system in your template world, is just a very thin placeholder, with very few behaviors attached to it. The Monkey toks are not set to be aggro, but in a play instance, if you attack them, they will attack back.
Logged

Grogard

  • World Owners
  • ****
  • Posts: 36
    • View Profile
Re: Agent already in combat state - So NPC don't attack me
« Reply #2 on: Jan 24, 13, 01:13:48 AM »

Hm. Very strange. When I first time go to play instance One money dont agto to me, but second one agro to me when i attack it. And after respounce they both dont attack me.

I add some debug message to the E_AIAgent and when i atack it? I always get:
Code: [Select]
[hsl_debug] 9223372056476021763,4: SCRIPT[E_AiAgentClassMethods]: Already in combat, so we don't care.
Logged

Thazager

  • General Accounts
  • *
  • Posts: 1117
  • Never stop learning
    • View Profile
    • Heroes and Villains MMORPG
Logged
Heroes and Villains Lead programmer/scripter
Exile Online Lead programmer/scriptor