HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Fixed in Sapphire.L] Scaled SpeedTrees are a Performance Hit when Translating  (Read 1895 times)

PN-Dwight

  • General Accounts
  • *
  • Posts: 465
    • View Profile
    • Pirates' Nest

Select the random rotation and random scale button, and spawn a speedtree.

I'm going from 90 fps to 7 fps in the area after I placed the speedtree. Tested in a clean area, and the issue persists.

Further investigation: the random rotation solely works great.
« Last Edit: Dec 11, 16, 01:14:02 PM by HE-SARRENE »
Logged

Jrome90

  • General Accounts
  • *
  • Posts: 330
    • View Profile
Re: Random Scale results into lag!
« Reply #1 on: Feb 08, 13, 04:22:18 AM »

Setting the scale to anything but 1,1,1 and moving the tree results in a significant fps drop until you stop moving it.
« Last Edit: Feb 08, 13, 05:28:14 AM by Jrome90 »
Logged

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Random Scale results into lag!
« Reply #2 on: Feb 08, 13, 07:52:02 AM »

I noticed that once on a really high poly tree, but sounds like there might be a wider spread issue there.
Logged

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Scaled SpeedTrees are a Major Performance Hit when Translating
« Reply #3 on: Feb 08, 13, 12:41:38 PM »

Reproed. It looks like all speedtrees are a major performance hit when translating them.

1. Place a speedtree
2. Set it's scale to 2,2,2
3. Select it with the Dynamic placement tool and move it around

Framerate drops noticeably. When following the same repro steps with a 1,1,1 tree, no performance hit.
Logged

HE-CHRISTOPHER

  • HeroEngine
  • *****
  • Posts: 424
    • View Profile

Fixed in the next release.
Logged
Christopher Larsen
CTO
HeroEngine