HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.
Pages: [1] 2

Author Topic: Errors When Loading Dynamic Player Models  (Read 3243 times)

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Errors When Loading Dynamic Player Models
« on: May 21, 13, 08:11:55 PM »

We've been trying to set up a dynamic player model in the engine, but we keep getting errors like these:


!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/m_human_average/m_human_average.dat

!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/human_male_pc/parts/human_male_pc.dat


Our character artist has followed the various wiki tutiorial carefully, and looking at the repository browser, everything looks to be in the right place - the dynamic2 folder in the Character folder.
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #1 on: May 21, 13, 09:47:30 PM »

the engine is looking for the dat files at those locations in the repo, but they aren't there. Are they actually in that location but still throwing the error?
Logged

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Errors When Loading Dynamic Player Models
« Reply #2 on: May 22, 13, 07:06:05 PM »

Ok, those seemed to have been uploaded incorrectly, so we've fixed that now - but we're still having some problems with viewing the mesh, which we think are texture related, so we'll work on those tomorrow.

Should textures for characters be stores in the dynamic2 folder as well, or can they be put in our main texture folder?
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

uexilon

  • General Accounts
  • *
  • Posts: 62
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #3 on: May 23, 13, 06:14:36 AM »

I had quite a fight with dynamic characters too ;)

Don't know if you have seen that post:
https://community.heroengine.com/forums/index.php/topic,4321.msg25356.html#msg25356

I tried their to explain the folder structure and so on.



Textures located in the maps folder, hgm mesh files in the parts folder, hgm animations in the animation folder.

You may need to check material names and paths if the problems still persist.  Sometimes there's also a problem if you first skin the parts to the skeleton and apply xform modifier &/ Reset scale afterwards (wrong placed, scaled parts).

Of course you can put all maps of all the models into one folder, you'd just need to reexport the parts with the correct paths.


If problems persist, could you upload a screen on how the model is displayed?
« Last Edit: May 23, 13, 06:20:13 AM by uexilon »
Logged

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Errors When Loading Dynamic Player Models
« Reply #4 on: May 27, 13, 05:57:04 PM »

We'res till having issues gettinh the meshes to show up - we can spawn them correctly, and get a message that the mesh has been registered, but they're still invisible.

As they've been test loaded in other engines, we're petty certain that it must be something that we're doing wrong with the text files for them, so I'm going to copy paste them here, and hopefuoly someone will be able to point out where we're making a mistake:


The .DAT file:

Quote
!
! Character Specification for Character\human_male_pc\parts\human_male_pc.DAT
!
!
Version=2
[PARTS]
  Model=m_human_average.dyc
  AnimationSetFolder=character\human_male_pc\animations
  Agent=character\human_male_pc\human_male_pc.aas
  Behavior=PlayerCharacter2
  Gender=Male



The .DYC file:

Quote
Version=1
[SETTINGS]
  Skeleton[Human]=Character\Dynamic_2\human_male_pc_skeleton.hgm
  PartsSpec=Character\Dynamic_2\human_male_pc\parts\m_human_average.par



The .PAR file:

Quote
! bang to comment line
! Human Parts definition file
!
[Root]
Character\Dynamic_2\human_male_pc\parts

[Slots]
!
! The slots are the areas defined for the Human in which various parts can go
!
Head
Torso
Left Arm
Left Hand
Right Arm
Right hand
Legs
Left Foot
Right Foot

[Divisions]
Head: Head
Upper Body: Torso,Left Arm,Left Hand,Right Arm,Right Hand
Lower Body: Legs,Left Foot,Right Foot

[Parts]
!
! Slot: Part, Mesh file
!
Head: Head,m_human_average_head<span style="background-color: navy; color: white; " />.hgm

Torso: Torso,m_human_average_body<span style="background-color: navy; color: white; " />.hgm   

Left Arm: Left Arm,m_human_average_arm_l<span style="background-color: navy; color: white; " />.hgm

Right Arm: Right Arm,m_human_average_arm_r<span style="background-color: navy; color: white; " />.hgm   

Left Hand: Left Hand,m_human_average_hand_l<span style="background-color: navy; color: white; " />.hgm   

Right Hand: Right Hand,m_human_average_hand_r<span style="background-color: navy; color: white; " />.hgm   
   
Legs: Legs,m_human_average_legs<span style="background-color: navy; color: white; " />.hgm   

Left Foot: Left Foot,m_human_average_foot_l<span style="background-color: navy; color: white; " />.hgm 

Right Foot: Right Foot,m_human_average_foot_r<span style="background-color: navy; color: white; " />.hgm
 
[Banks]
human_male_pc
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

uexilon

  • General Accounts
  • *
  • Posts: 62
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #5 on: May 28, 13, 02:12:19 AM »

<span style="background-color: navy; color: white; " />

Is this in your file?

If yes, that would be quite a easy solution I think.. Is it possible that you copied it from the wiki? This <span style="background-color: navy; color: white; " /> is there by mistake.. Or at least i deleted it and it (still works).
After all it's just the name of the hgm file and there's no reason for this <span style="background-color: navy; color: white; " /> to be between the name and the .hgm

Give it a try..


+ recheck your path's one isn't leading to a subfolder of the dynamic_2 folder while the rest does.. Just to make sure all path's are like they should be.
« Last Edit: May 28, 13, 02:17:29 AM by uexilon »
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #6 on: May 28, 13, 11:04:19 AM »

Usually the Animation Agent (.aas file) is located within the animation folder, but the path listed in the .dat file:

"Agent=character\human_male_pc\human_male_pc.aas"

has it located in the main character folder.  Is that the correct path for the .AAS file?
Logged

AlmightyGir

  • Developers
  • *
  • Posts: 24
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #7 on: May 28, 13, 01:55:33 PM »

Usually the Animation Agent (.aas file) is located within the animation folder, but the path listed in the .dat file:

"Agent=character\human_male_pc\human_male_pc.aas"

has it located in the main character folder.  Is that the correct path for the .AAS file?

hey Bennett,

So the error i'm getting now is:
Quote
!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/human_male_pc/animationsanimationset.dat
!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/human_male_pc_skeleton.hgm
!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/human_male_pc/character/dynamic_2/human_male_pc/parts/m_human_average.par

any idea what those could be?
Logged

uexilon

  • General Accounts
  • *
  • Posts: 62
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #8 on: May 28, 13, 02:20:39 PM »

Have you checked whether the files are really located there?
The paths look pretty messed up...
/character/dynamic_2/human_male_pc/animations/animationset.dat
/character/dynamic_2/human_male_pc/human_male_pc_skeleton.hgm
/character/dynamic_2/human_male_pc/character/dynamic_2/human_male_pc/parts/m_human_average.par

if it throws an error out, that there's a file missing then it's simply missing :S Well sometimes you need to restart heroblade thought, but afterall if the files are where they should be, then it works quite well..

There must be something wrong with the files.. I'd recommend to open the folder and every text file and then really check through every single path. i had also problems but never that many.. So it must be rather something "simple" (that doesn't mean it's allways easy to finde them ;) )
Logged

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Errors When Loading Dynamic Player Models
« Reply #9 on: May 28, 13, 04:15:06 PM »

We're working to fix this, but we seem to be unable to delete folders from the repository browser.

EDIT: We're basically looking to wipe away the previous attempts to load the models and parts ,and start from the beginning again - but they're still showing as red, even when deleted, and they're blocking our ability to reupload the newer versions.
« Last Edit: May 28, 13, 04:23:47 PM by Amanda_Brooks »
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

Chromehound

  • General Accounts
  • *
  • Posts: 151
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #10 on: May 28, 13, 04:28:05 PM »

if you're using the same path & filename, restore the file (right click, view history), and then upload the new one to overwrite.

Nothing gets deleted.
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #11 on: May 29, 13, 09:14:55 AM »

DNA_Chrome has the right of it, just overwrite the old folders.  If anything was actually deleted during the development process it wouldn't be recoverable, which would make for a rather poor versioning system!
Logged

AlmightyGir

  • Developers
  • *
  • Posts: 24
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #12 on: Jun 01, 13, 10:47:50 AM »

managed to get the character showing up in game. we now have a new problem!




our character shows up as a giant gelatinous blob!

our error log shows:
Quote
!ERROR!System:  Synchronous repository request ERROR for: /character/dynamic_2/human_male_pc/animation/idle.hgm, result FACE000F : __FUNCTION__: must be attached to a repository
!ERROR!System:  FAILURE: stop of [idle.hgm] attempted when it was not playing
!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /character/dynamic_2/human_male_pc/animation/idle.hgm


i can't see how the lack of an animation could do this. i've checked and reset x-forms within max, checked scaling etc and it should all be okay.

any thoughts? is this likely to be tied to the skeleton currently having more bones than officially supported? because it definitely seems like a mesh issue.
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Errors When Loading Dynamic Player Models
« Reply #13 on: Jun 03, 13, 01:52:03 PM »

No, the bone count isn't the issue.  Having too many bones just forces the calculations to be done on the CPU instead of the GPU.

It is entirely possible that the lack of an animation could cause what you're seeing.  I would try and fix that first.
Logged

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Errors When Loading Dynamic Player Models
« Reply #14 on: Jun 03, 13, 08:04:52 PM »

We've tried re-exporing the idle animation we're using, and have set up our folders to copy the layout of the default HE dynamic models, and we're still getting console errors telling us that the engine can't find the idle animation - does anyone have any suggestions as to what we might be doing wrong?
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios
Pages: [1] 2