HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.
Pages: 1 [2]

Author Topic: [Fixed in sapphire m] SubstituteFont  (Read 4542 times)

JoshHalls

  • Founding Professional
  • *****
  • Posts: 335
    • View Profile
    • The Repopulation
Re: [RESOLVED] SubstituteFont
« Reply #15 on: May 13, 13, 03:53:39 PM »

Plus we have other odd issues with some labels with them not rendering properly (might be a scaling issue, haven't had a ton of time to dig into it). These issues aren't present when the font is installed locally.
Logged
Co-Owner/Programmer - The Repopulation

jcsmith562

  • General Accounts
  • *
  • Posts: 190
    • View Profile
Re: [RESOLVED] SubstituteFont
« Reply #16 on: May 15, 13, 01:50:53 PM »

This should definitely not be flagged as Resolved. Going into fly mode sometimes spams the console like mad with this fix also. So while it helps i some ways it causes other errors. Here's the spam from camera:

FILERESPONSE: RepositoryThunk::GotFirestormCallback,/gui/fonts/ubuntu.ttf,1,SUCCESS

Logged

HE-CHRISTOPHER

  • HeroEngine
  • *****
  • Posts: 424
    • View Profile
Re: [RESOLVED] SubstituteFont
« Reply #17 on: May 30, 13, 08:45:01 AM »

We have identified an issue where fonts from the repository and registered via the external functions for that purpose were not maintaining a reference in the font manager.  This will be fixed in Sapphire.M.
Logged
Christopher Larsen
CTO
HeroEngine

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: [Fixed in sapphire m] SubstituteFont
« Reply #18 on: May 30, 13, 02:40:22 PM »

That's great to hear - any ETA on when that update might go live?
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: [Fixed in sapphire m] SubstituteFont
« Reply #19 on: May 30, 13, 06:01:15 PM »

You might be misunderstanding the fix Amanda. The only needed fix is the unnecessary call to the repo on load everytime. So you'd pretty much only care about the fix at the public testing phase to ensure streamlined goodness.
Logged

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: [Fixed in sapphire m] SubstituteFont
« Reply #20 on: May 30, 13, 08:28:25 PM »

So this won't solve our current issue of our chosen font not displaying properly in our UI?
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: [Fixed in sapphire m] SubstituteFont
« Reply #21 on: May 31, 13, 04:49:07 PM »

Correct. Read through this thread for possible reasons why you're syntax or path are not being input correctly.
Logged

JoshHalls

  • Founding Professional
  • *****
  • Posts: 335
    • View Profile
    • The Repopulation
Re: [Fixed in sapphire m] SubstituteFont
« Reply #22 on: Jun 07, 13, 06:01:52 PM »

This has seemed to resolved our issues so far with the fonts. Was one odd thing I noticed on one of our test machines we need to investigate, but the rest of the issues that we were seeing before are not present. Loading/switching them as well seems to be working well.
Logged
Co-Owner/Programmer - The Repopulation
Pages: 1 [2]