HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: Maya HeroMaterial to HeroEngine Doesn't Work PLEASE HELP!  (Read 2117 times)

Firefly1213

  • Developers
  • *
  • Posts: 7
    • View Profile

Hello!

I am creating models for a video game using the HeroEnigne Art Tools for Maya and I am having an issue with the textures.  I have applied the HeroMaterial and assigning a .dds texture file to the HE folder I setup on my C: Drive.

Through all the tutorials on the wiki, it says that assigning the material to this folder should work when I transfer my model and texture to the same path (after the HE folder) on the Repository Browser.  I double and triple checked everything and when I login to test the model and texture, the model shows but it flashes with mutlicolors.

Please help me out!
Thank you!

Also, I'm using Maya 2013 with the proper tools from HeroEngine. 

Thanks again!
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Maya HeroMaterial to HeroEngine Doesn't Work PLEASE HELP!
« Reply #1 on: Jul 15, 13, 01:41:45 PM »

Are you getting an error in the console? 
Logged

Firefly1213

  • Developers
  • *
  • Posts: 7
    • View Profile
Re: Maya HeroMaterial to HeroEngine Doesn't Work PLEASE HELP!
« Reply #2 on: Jul 15, 13, 01:54:16 PM »

Here is the errors I'm getting, but I don't know how to fix the textures.

!ERROR!System:  Async repository request ERROR for: '/', invalid filename
!ERROR!Material:MATERIAL REDEFINITION ERROR:  Material [HeroShader1] was first defined in file [\objects\misc\testball\test.hgm] and then redefined by file [\objects\misc\baseball.hgm]   Reason: The second material's setting for DiffuseMap (/new_textures/textures1/baseball01.dds) does not match the first material (/c:/users/jesse/desktop/balltest.dds).  Materials sharing a name must have identical settings, fix the art by eliminating the differences or renaming one of the materials and then restart HeroBlade.


I think it's trying to load this texture even though the HeroMaterial in Maya is set to (/new_textures/textures1/baseball01.dds)

!ERROR!System:ERROR: Not found (0xFACE000F) loading resource: /c:/users/jesse/desktop/balltest.dds

Logged

WorldWideZ

  • World Owners
  • ****
  • Posts: 524
    • View Profile
    • World Wide Zed
Re: Maya HeroMaterial to HeroEngine Doesn't Work PLEASE HELP!
« Reply #3 on: Jul 15, 13, 02:08:47 PM »

looks like you have used a non unique material name ([heroshader1])

you can  re export baseball with a new material name ( i would suggest [gamename]_[username]_[objectname]_[texturename] or come up with a naming system you can stick too)
Logged

Firefly1213

  • Developers
  • *
  • Posts: 7
    • View Profile
Re: Maya HeroMaterial to HeroEngine Doesn't Work PLEASE HELP!
« Reply #4 on: Jul 15, 13, 02:21:50 PM »

Thank you! Thank you! Thank you! THANK YOU!

It WORKS!

THANK YOU SOOOOOO MUCH!
Logged