HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.
Pages: 1 [2]

Author Topic: Why do normal maps show incorrectly ?  (Read 4200 times)

gaarzen

  • General Accounts
  • *
  • Posts: 99
    • View Profile
Re: Why do normal maps show incorrectly ?
« Reply #15 on: Nov 14, 13, 10:03:12 PM »

Hey guys,
we're still very stuck with this issue :-\
I hope a way to to fixing it is indeed possible.

Thanks

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Why do normal maps show incorrectly ?
« Reply #16 on: Nov 14, 13, 10:49:49 PM »

Can you give more details about the way in which normal maps aren't working?
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

gaarzen

  • General Accounts
  • *
  • Posts: 99
    • View Profile
Re: Why do normal maps show incorrectly ?
« Reply #17 on: Nov 15, 13, 03:34:57 PM »

Can you give more details about the way in which normal maps aren't working?
Hey,
please tell me what exactly to show, I'll do anything :)
My latest test was hardening all the edges of the object and splitting the different areas in the UV layout, creating the attached normal map.
Although it looks good in Studio Max, Maya and Marmoset Toolbag it doesn't look good in HE and the seams are visible and dark like seen in one of my last messages in this thread.

Thanks !!
« Last Edit: Nov 15, 13, 04:10:10 PM by gaarzen »
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: Why do normal maps show incorrectly ?
« Reply #18 on: Nov 19, 13, 04:55:56 PM »

Many things vie for my attention, but if you're still having an issue I can try and look into this further tomorrow.

To rule out some things I'll probably want to log into your world from here and take a look at the asset.  Can you create a test area with just that asset in it?
Logged

gaarzen

  • General Accounts
  • *
  • Posts: 99
    • View Profile
Re: Why do normal maps show incorrectly ?
« Reply #19 on: Nov 19, 13, 05:37:52 PM »

Many things vie for my attention, but if you're still having an issue I can try and look into this further tomorrow.

To rule out some things I'll probably want to log into your world from here and take a look at the asset.  Can you create a test area with just that asset in it?
Oh please do ! Unfortunately I still haven't found a way to work it although I tried several different things.
I created a new area called "Normal Map Problem Scene" and in that scene there is the object.
I also change the UV and normal map to have much larger gaps between UV islands to make sure the problem doesn't have to do with them being too close.

Thanks a lot !
« Last Edit: Nov 19, 13, 06:02:18 PM by gaarzen »
Logged

gaarzen

  • General Accounts
  • *
  • Posts: 99
    • View Profile
Re: Why do normal maps show incorrectly ?
« Reply #20 on: Nov 20, 13, 05:09:35 PM »

SUCCESS !!
Well, almost anyway.
I took the normal map into photoshop and flipped the green channel and now the object looks just as it should in HE ! However, it only looks well without specularity on, specularity causes the creases to be dark and visible ???

Pages: 1 [2]