HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: A couple of questions (3ds max models)  (Read 1451 times)

SilverkeyRoy

  • World Owners
  • ****
  • Posts: 3
    • View Profile
A couple of questions (3ds max models)
« on: Feb 20, 14, 03:17:45 PM »

Good evening all!

I must first make clear that we are newcomers to working with Heroengine (HeroCloud), and thus we where bound to run into some issues.

We've made some simple models to import into the Engine for use ingame- we eventually figured out how to do this but only with one object at a time, so not entire models. How can we import the entire model into the HE?

Secondly the models that we do manage to import have messed up textures. instead of the filled in overal textures the texture is heavily multiplied.

To better explain what I mean with how it should look and what happens after importing Ive added these pictures

How it should look.


How it looks.


We hope you guys can help us understand what we're doing wrong with the textures.
:the textures are all in DXT1 .dds, the normal map as well. the image size is equal.
the texture ball also shows an unlimited amount of copies of a texture instead of a one large texture.



Oh..we're using 3DS max 2013

Kind Regards
Roy van der Steen
Philip van Houwelingen
Peter van Boksel.
Logged

WorldWideZ

  • World Owners
  • ****
  • Posts: 524
    • View Profile
    • World Wide Zed
Re: A couple of questions (3ds max models)
« Reply #1 on: Feb 20, 14, 03:34:31 PM »

If you mesh is made from multiple objects , convert them to editable polys and use the attach function to join them together. I am sure others will chime in on the textures , as a self taught max user i have my own unique (and probably arse about face) way of doing things. Although i do use DXT 5 for my models textures, not sure what difference that is been a while since i read up on what the differences are.
Logged

SilverkeyRoy

  • World Owners
  • ****
  • Posts: 3
    • View Profile
Re: A couple of questions (3ds max models)
« Reply #2 on: Feb 20, 14, 03:41:05 PM »

Thanks for the swift responds, this will really help us get going again!
Now just the texture issue and we can finally really get started.
Logged

Chromehound

  • General Accounts
  • *
  • Posts: 151
    • View Profile
Re: A couple of questions (3ds max models)
« Reply #3 on: Feb 21, 14, 09:10:08 AM »

What does your uv map look like?  Also did you use the Hero plugin & material within Max?

DXT1 for basic textures, DXT5 if you have transparency
Logged

SilverkeyRoy

  • World Owners
  • ****
  • Posts: 3
    • View Profile
Re: A couple of questions (3ds max models)
« Reply #4 on: Feb 21, 14, 09:25:26 AM »

apparently we did something wrong with the UV unwrap! we've solved the texturing issue, well sort off.
Now we need to find a way to rid outselves of the gloss on our objects.
Logged

HE-BENNETT

  • HeroEngine
  • *****
  • Posts: 559
    • View Profile
Re: A couple of questions (3ds max models)
« Reply #5 on: Feb 21, 14, 01:33:26 PM »

The gloss you are referring to is caused by a combination of the lighting setup in the area and the specular values associated with the asset.  If you apply a simple normal map to the asset, you can include a specular map in the alpha channel of the normal to reduce or remove the "gloss".

Logged