HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: Does the prop system honor model properties?  (Read 949 times)

NestEggs

  • World Owners
  • ****
  • Posts: 24
    • View Profile
Does the prop system honor model properties?
« on: Apr 05, 14, 12:10:48 PM »

Hi folks,

I'm back looking at the rendering side of the prop system. If you look at the image here: the model on the left was added by Create->Library->CleanEngine->IceBlock1.hgm. The model on the right is added through the props system with the command:

Code: [Select]
/heprops library #spec='6'  #fqn='\world\livecontent\Resources\TestModels\IceBlock1.hgm' #position='$POSITION' #lod='10'
The prop spec uses the _PropVisualizationDecorator and I don't see any lighting overrides in there. Is this a bug or am I missing something?

Thanks,
Chris
Logged

HE-Cooper

  • *****
  • Posts: 2221
    • View Profile
Re: Does the prop system honor model properties?
« Reply #1 on: Apr 05, 14, 05:57:05 PM »

At cursory glance it looks like you have the two blocks in different rooms, and thereby different environment schemes, with different lighting properties.
Logged

NestEggs

  • World Owners
  • ****
  • Posts: 24
    • View Profile
Re: Does the prop system honor model properties?
« Reply #2 on: Apr 05, 14, 08:55:36 PM »

Thanks Cooper,

That's exactly what's going on. Props are being added to "*everywhere*" instead of the currently selected room. Is this by design?

Thanks,
Chris
Logged