HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [RESOLVED]-Quartz.d-PlayerClient Hangs at Splash Screen  (Read 4326 times)

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile

Haven't seen anything else about this, but after uninstalling/deleting, reinstalling the player client numerous times since the patch, it won't get past the splash screen.  we use the client alot for testing various things.

I can log in, select world, then it locks up at the Hero Engine splash screen.  Its sat for hours with no change.

Anyone else having issues with this?

We're happy with the new changes (especially the server/client dom/gom editors!)

Thanks
« Last Edit: Apr 28, 15, 10:04:55 AM by ToY-Krun »
Logged

HE-HERB

  • HeroEngine
  • *****
  • Posts: 530
    • View Profile
    • HeroEngine
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #1 on: Apr 23, 15, 10:29:58 AM »

Does HeroBlade work?  Which server / world?

Cheers
Logged
herb marselas
graphics guy

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #2 on: Apr 23, 15, 11:06:12 AM »

Yes, the blade works, repository browser works; just not the generic player client.

Tales of Yondalyr server/world

I'm in the process of fixing some non-pwr of 2 textures but since those have been UN fixed for a while I didn't think they would be causing the client to hang up.

Two things im working on (have put it off for a while) are some rigid meshes in some of the characters, and the power of 2 issue.

HE-HERB

  • HeroEngine
  • *****
  • Posts: 530
    • View Profile
    • HeroEngine
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #3 on: Apr 23, 15, 02:58:33 PM »

It's difficult to run the player client on the world due to script error spam which is slowing things down.

You can probably get in using HeroBlade as it runs more slowly than the player client, and has different mechanisms for handling the script errors.

I would suggest resolving the errors, which should fix the issue


Cheers
Logged
herb marselas
graphics guy

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #4 on: Apr 23, 15, 03:03:44 PM »

hrm, ill look into it, but im not seeing script errors other than a travel system error that occured as you left.
Of course I cant see if the client might be throwing some errors that the blade isnt.

The client always loads up in around 10 seconds or less, that is until the update.

do you by chance have a copy of the error strings?

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #5 on: Apr 23, 15, 03:12:39 PM »

Following is a list of everything that occurs prior to and including, loading into Character selection:

Console:
16:08:29: HeStartup Call...
16:08:29: SYSTEM:System:Windows version: 6
16:08:30: SYSTEM:system:Game Scale set to: 10.00
16:08:30: SYSTEM:System:Initializing HeroBlade DLL
16:08:30: SYSTEM:System:SelectionManager::Startup()
16:08:30: SYSTEM:System:GUIControl::SetupScreen()
16:08:30: SYSTEM:System:Audio plugin [FMOD] initialized successfully
16:08:30: SYSTEM:System:Audio plugin [FMOD Studio] initialized successfully
16:08:30: SYSTEM:System:DebugVisualizer Setup
16:08:30: System:HeroEngine Client DLL told version is: 2.6.0.25406
16:08:35: SYSTEM:firestorm:BaseApplication::initialize   Service_Directory_Client   1429819714526   8
16:08:37: BillingChannelCallback:Message:
16:08:40: SCRIPT:[_InputHandlerClassMethods]:_OnKeyBindingsLoaded: , /heroenginekeybindings.ini
16:08:40: SCRIPT:[_InputHandlerClassMethods]:_OnKeyBindingsLoaded: , /gamekeybindings.ini
16:08:41: ERROR:System:XML file /guixml/hasvaluespeceditorpanel.xml not found
16:08:41: ERROR:System:XML file /guixml/itemspeceditorgui.xml not found
16:08:41: ERROR:System:XML file /guixml/itemvisualizerspeceditorpanelgui.xml not found
16:08:41: ERROR:System:XML file /guixml/itemvisualizationspeceditorpanel.xml not found
16:08:41: Refreshing areaOrganizer.
16:08:45: SYSTEM:System:  Activating Segment: demoland
16:08:45: SYSTEM:System:Reset the synchronized clock.
16:08:45: SYSTEM:System:ActivateAreaSpec 3758002374 assigning ID 1 instance 1
16:08:45: SCRIPT:[E_playerAccountClassMethods]:Loaded Charcter Appearance
16:08:45: SCRIPT:[E_AiAgentClassMethods]:Gonzo waking up
16:08:45: SCRIPT:[E_playerAccountClassMethods]:rep group added, Making character
16:08:45: SYSTEM:System:Character Selection (3758002374) activate
16:08:46: SCRIPT:[E_BaseClientClassMethods]:Area Loaded
16:08:46: SCRIPT:[E_CharacterSelectionGUIClassMethods]:css window loading up
16:08:46: SCRIPT:[E_characterSelectionClassMethods]:loading css
16:08:46: SCRIPT:[_characterSelectionClassMethods]:Got updated names...



Script Error panel : nothing

Error panel: nothing


This is from logging in with the blade.  The client doesn't reach this point at all, so I'm wondering if you're seeing errors when logging in with the player client that i can't see?



*EDIT*
This is from logging from character selection into home area:

Console panel:

Code: [Select]

16:13:11: SCRIPT:[E_CharacterSelectionGUIClassMethods]:Nala_Balola
16:13:11: SCRIPT:[E_CharacterSelectionGUIClassMethods]:me E_CharacterSelectionGUI
16:13:18: SYSTEM:System:SUA purging active area
16:13:18: SYSTEM:System:Character Selection (3758002374) PURGE
16:13:18: SYSTEM:System:Purging EnviroSchemes
16:13:18: SYSTEM:system:Released area 1
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Dandridge Mine
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Dandridge Docks
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Tafft's Pub
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Aces Shack
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Dandridge Keep
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Dandridge GateHouse
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Dandridge
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Crag Farm
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:Tag's Pit
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:SeaView Village
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:instantiated placeorthing node
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:placeorthing node unmarshalled for UPDATE
16:13:20: SCRIPT:[PlaceOrThingClassMethods]:SeaView Docks
16:13:20: BillingChannelCallback:Message:
16:13:20: SYSTEM:System:Reset the synchronized clock.
16:13:20: SYSTEM:System:ActivateAreaSpec 9223372095314023329 assigning ID 9223372095314023329 instance 0
16:13:21: ERROR:System:PhysX:  not finished loading yet!  Returning a fake collision at the character position to prevent falling
16:13:25: ERROR:System:ERROR: Not found (0xFACE000F) loading resource: /world/livecontent/terrainmaps/generic/dirt_mud/dirt_fresh_tilled01_n.dds
16:13:26: SYSTEM:System:GES Requesting resource /eur_southeastcoast.ges(1000000317)
16:13:26: SYSTEM:System:Dandridge (9223372095314023329) activate
16:13:29: SCRIPT:[E_playerAccountClassMethods]:Loaded Charcter Appearance
16:13:29: SCRIPT:[PER_AvatarClassMethods]:OnControlBuild
16:13:29: SCRIPT:[PER_AvatarClassMethods]:Loading portrait : /LocalClientStorage/ScriptLocalData/portraits/Nala_.dds
16:13:29: SCRIPT:[PER_AvatarClassMethods]:getting delayed texture
16:13:29: SCRIPT:[E_AiAgentClassMethods]:Nala waking up
16:13:29: SCRIPT:[E_playerAccountClassMethods]:added character : Nala
16:13:29: SCRIPT:[E_playerAccountClassMethods]:rep group added, Making character
16:13:29: System:PushLayer(GUIEditor)
16:13:29: System:PushLayer(Camera)
16:13:29: System:PushLayer(Mouse)
16:13:29: System:PushLayer(Movement)
16:13:29: System:PushLayer(Command)
16:13:30: SCRIPT:[E_BaseClientClassMethods]:Area Loaded
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SCRIPT:[AbilityClassMethods]:instantiated ability node
16:13:30: SYSTEM:System:GES Requesting resource /eur_southeastcoast.ges(1000000895)
16:13:30: SYSTEM:System:GES Requesting resource /eur_southeastcoast.ges(1000000899)
16:13:32: WARNING:graphics:PERFORMANCE WARNING: Texture [/render/weather/side_splashes.dds] size 960x198 is not a power of 2, and must be converted on load
16:13:32: WARNING:graphics:PERFORMANCE WARNING: Texture [/render/weather/top_splashes.dds] size 960x165 is not a power of 2, and must be converted on load

the only errors was a texture i just deleted a bit ago as its not ours, and the power of 2 errors at the end.
Again this was with the blade not the player client
« Last Edit: Apr 23, 15, 03:18:43 PM by ToY-Krun »
Logged

HE-HERB

  • HeroEngine
  • *****
  • Posts: 530
    • View Profile
    • HeroEngine
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #6 on: Apr 23, 15, 03:15:43 PM »

There's a lot of these errors - looks like every frame:

ERROR:System:SCRIPT ERROR: node id 0 not found
Time:04/23/2015 12:46:38
Call trace:
  Script E_AiAgentClassMethods line 1004 me[9223372055737961503]
  Script E_AiAgentClassMethods line 135 me[9223372055737961503]
  Script E_AiAgentClassMethods line 688 me[9223372055737961503]
starting method/function _AIAGENTBRAIN_TICK
starting me[id=9223372055737961503 class=E_playerCharacter,_SocialPlayerCharacterDataOwner]
ERROR:System:SCRIPT ERROR: node id 0 not found
Time:04/23/2015 12:46:38
Call trace:
  Script E_AiAgentClassMethods line 1004 me[9223372055737961503]
  Script E_AiAgentClassMethods line 135 me[9223372055737961503]
  Script E_AiAgentClassMethods line 688 me[9223372055737961503]
starting method/function _AIAGENTBRAIN_TICK
starting me[id=9223372055737961503 class=E_playerCharacter,_SocialPlayerCharacterDataOwner]


And, many of these, although I don't have a stack / context:

ERROR:HeroScript::HeroMachine::ScriptError:node id 0 not found
ERROR:HeroScript::HeroMachine::ScriptError:node id 0 not found




Cheers
Logged
herb marselas
graphics guy

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #7 on: Apr 23, 15, 03:22:18 PM »

Ahh, those are due to race/model choice as only one is being used atm. 
But those would have occured after reaching character select when the playercharacter is loaded, or after logging into the game world itself.  we cant get the player client to get to character select.

I'll try reinstalling one more time.  its obvious you're getting well beyond the point we are, so it must be something with the installation.

ConvertibleTurtle

  • General Accounts
  • *
  • Posts: 15
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #8 on: Apr 23, 15, 07:53:49 PM »

I'm having the same issue. I am able to wake up the world, then choose to login, and eventually choose the world, but once I attempt to bring open my world, it just hangs at a black screen after the HeroEngine logo.

Edit: The reference world's also will not load, same behavior. The PC I am using is only used for Hero Engine. So not sure what's going on.

Edit #2: After many moments of waiting, the blade is finally loading. It appears that the uninstall and reinstall fix requires a much longer time for initial load than the initial install.
« Last Edit: Apr 23, 15, 08:27:47 PM by ConvertibleTurtle »
Logged

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #9 on: Apr 23, 15, 08:38:53 PM »

Still hasnt worked for the player client.  On top of that in the process of tracing script after script trying to determine why the client can't reach character selection, we've now got a loop going thats impossible to break.

I've narrowed it(i think) to playerconnection.  not sure what changed that would have caused this though.

If  Herb, or Cooper or someone could possibly revert the E_PlayerConnection script back one notch I'll try to narrow it down further.  No way to get back in on our end as its looping through the arns imediately on account connection, effectively locking up the blade.

thanks

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #10 on: Apr 27, 15, 09:29:45 PM »

The only errors we're getting now on the player client are the following:

ERROR:Mesh:Error - No mesh library found to support (hgm): /character/dynamic_2/sheelf/sheelf_skeleton.hgm


and same error with multiple .hgm files

This is from the .Log file, and only occurs using the player client, not the blade.

I'm not familiar with this error, and doesn't really make sense to me atm.   

Any ideas?  These aren't new models, have been using them for over a year. 
Is there something wrong with the models themselves perhaps?
Not just character models but all models.

Again, this only happens on the player client.
Got the client to login to character select by overriding _CSSOnSpinUpRegisterCharacterSpecifications()
and registering our own default model.  The character_sample model threw an error that stopped login for some
reason.

Now it logs into the world , but the splash screen remains, as all the models in the area throw the error above.

Thanks

Amanda_Brooks

  • General Accounts
  • *
  • Posts: 514
    • View Profile
    • Heroes and Villains
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #11 on: Apr 27, 15, 09:33:22 PM »

We've noticed this too - ours hangs at about 66%.
Logged
"Heroes and Villains" - www.heroes-and-villains.com
Facebook: https://www.facebook.com/HeroesAndVillainsMMORPG
Twitter: @Plan_Z_Studios

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #12 on: Apr 27, 15, 09:45:28 PM »

Yeah ours did the same thing.  I overrode that method to get logged into the world, but theres no graphics.

If you check the log file (if you have logging turned on) you'll probly see the same errors in there.
run the client, leave it open and check the log file located in users\name\appdata\local\heroengine\logs
at least thats my location.  The filename is heroengine.log

The first error on our list was regarding the default character model (character_sample.hgm) by overriding that with our own we were able to log all the way in, however with no models or heightmaps.  All the models still throw the same error but for some reason that default char model was holding up the process at 66%.

HE-HERB

  • HeroEngine
  • *****
  • Posts: 530
    • View Profile
    • HeroEngine
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #13 on: Apr 28, 15, 09:51:33 AM »

The C021 Player Client has been fixed and re-deployed.

Cheers
Logged
herb marselas
graphics guy

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Quartz.d-PlayerClient Hangs at Splash Screen
« Reply #14 on: Apr 28, 15, 10:04:37 AM »

Confirmed working.

Thanks guys

*EDIT*
And thanks for putting up with me and my guys the past several days =P*
« Last Edit: Apr 28, 15, 10:06:12 AM by ToY-Krun »
Logged