HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: Cursor Disappearing  (Read 1293 times)

Malumm

  • General Accounts
  • *
  • Posts: 35
    • View Profile
    • SynapticSwitch
Cursor Disappearing
« on: Jun 02, 15, 02:59:23 PM »

When using the editor, my cursor randomly disappears and will not come back until I close and re-open hero blade.

I have had this issue for a long time but now my fix of disabling the cursor and re-enabling it through script does not work anymore.

Can anyone help?
 
Logged

BCI3DLLC

  • General Accounts
  • *
  • Posts: 64
    • View Profile
    • FoxySoft
Re: Cursor Disappearing
« Reply #1 on: Jun 10, 15, 11:50:30 PM »

try hitting shift esc or cntrl esc several times till the cursor comes back.  sometimes that works for us
Logged
Games for Grown Ups

HE-SCOTT

  • HeroEngine
  • *****
  • Posts: 158
    • View Profile
Re: Cursor Disappearing
« Reply #2 on: Jun 11, 15, 07:44:28 AM »

I assume you are referring to a custom cursor in the game view port when using the HeroBlade correct? There are several oddities with how C# works, which the HeroBlade UI is programmed in,  when dealing with cursors which are then compounded when using DirectX. This is unfortunately a limitation with C#. Rest assured though that when your game goes to launch none of these problems occur within the player client so end users will not experience this issue.

If you are referring to something different please write up a detail reproduction report on how to trigger the problem you are having and email it to support@heroengine.com.
Logged