HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: quartz g, setting up replication Destination Field (Client) in server DOM fails  (Read 3253 times)

AWW_boss

  • General Accounts
  • *
  • Posts: 846
  • gdfgd
    • View Profile

Hi! I cannot set Destination Field (Client) in server DOM more then once. I can set it once, but then i have to restart the client.

Since setting up replication fields is one of the basic coding tasks, could you please prioritize fixing this bug?

Also, i should be able to copy/paste the value in Destination Field (Client) instead of going through the drop down list.
Logged

HE-SCOTT

  • HeroEngine
  • *****
  • Posts: 158
    • View Profile

Can you please describe the problem you are having in more detail? In our testing we are able to change the same server DOM items client destination field multiple times and other classes' client destination as well with out having to restart. What happens that you are forced to restart?

How are you inputting the class you want for the client destination E.G. typing it in and then clicking on the item, typing it and then pressing enter, clicking the drop down and scrolling to select the item.

Copy/Pasting for that dropdown is something we will look at adding in time for the next release.
Logged

AWW_boss

  • General Accounts
  • *
  • Posts: 846
  • gdfgd
    • View Profile

Quote
How are you inputting the class you want for the client destination
It's not the class, it is the "Destination Field (Client)", a property of the server field.

I am setting the field by picking it from the drop down list. The problem is that hitting save in most cases does not bring the confirmation dialog.

I will see if i can get a solid repro case.
Logged

AWW_boss

  • General Accounts
  • *
  • Posts: 846
  • gdfgd
    • View Profile

Yeah, tried it again and it is rather glitchy. All i can say is that setting the field "Destination Field (Client)" and then clicking the Save button doesn't work most of the times, as there is no confirmation window for the dom commands.
I noticed though that if I set something else, for example "Initial priority", the confirmation window reappears and then i usually can set the "Destination Field (Client)" value.
I also noticed that i cannot set  "Destination Field (Client)" to an empty value.
Logged

HE-SCOTT

  • HeroEngine
  • *****
  • Posts: 158
    • View Profile

We believe we have identified most of the issues preventing field replication destinations from saving through the UI. CLI commands still work as always. We also corrected the issue which was preventing copy/pasting in those sections from working.

We are currently testing these changes to make sure we haven't missed anything, however these changes should go out with the next update.
Logged

AWW_boss

  • General Accounts
  • *
  • Posts: 846
  • gdfgd
    • View Profile

This still doesn't work.
To be more precise, a simplest scenario where i copy/paste the field value, doesn't work.
« Last Edit: Aug 20, 15, 03:40:40 PM by AWW_boss »
Logged

HE-SCOTT

  • HeroEngine
  • *****
  • Posts: 158
    • View Profile

How are you performing the copy paste? The copy paste functionality we added was specifically for replication destinations if you are referring to a different input we will take a look at that too. We have tested copy pasting from items outside of the editor, from a separate text file for example, and from the server destination to the client destination. Keep in mind when pasting it will still filter based on what you paste in so if there is not an exact match it will go to the closest match just as if you typed it in.
Logged

Jrome90

  • General Accounts
  • *
  • Posts: 330
    • View Profile

After Copy/pasting the values into the destination fields the save dialog shows up after clicking save  if, and only if  I hit enter after pasting the value.

« Last Edit: Aug 20, 15, 04:26:35 PM by Jrome90 »
Logged