HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: Find bug?  (Read 1765 times)

Thazager

  • General Accounts
  • *
  • Posts: 1160
  • Never stop learning
    • View Profile
Find bug?
« on: Feb 24, 16, 08:49:16 PM »

In the console window, I got an error:

20:33:01: ERROR:System:ERROR: Not found (0xFACE000F) loading resource: /gui/_mytemp.png
20:33:01: ERROR:System:ERROR: Not found (0xFACE000F) loading resource: /gui/_mytemp2.png

Doing a search (using /gui/_mytemp.png) through the scripts resulted in nothing found. I then checked the xml scripts (where it might be included in a prototype). It still showed nothing found.

When I did a partial search (using _mytemp) I found out why it was not found. The xml script has the value shown as:

value="\GUI\_mytemp.png"

The slashes are backwards, thus not finding it.  Any way to fix that "Find" check?
Logged
Lead scripter for EO, Repop helper.
HSL Video tutorials:
https://community.heroengine.com/forums/index.php/topic,1719.msg36858.html#msg3685

HE-CHRISTOPHER

  • HeroEngine
  • *****
  • Posts: 424
    • View Profile
Re: Find bug?
« Reply #1 on: Feb 24, 16, 10:03:26 PM »

The file path parsing mechanism regularizes the path in an attempt to correct for various invalid inputs.  However, correcting for invalid inputs one way may result invalid inputs for another use case.

HeroEngine uses a relative path mechanic (based on configuration internally and rarely changed from a standard) to locate files for specific purposes.

If you input the path as the engine expects does it function?

Logged
Christopher Larsen
CTO
HeroEngine

Thazager

  • General Accounts
  • *
  • Posts: 1160
  • Never stop learning
    • View Profile
Re: Find bug?
« Reply #2 on: Feb 25, 16, 12:18:07 AM »

Yes, it does find it using the slashes backwards, thus the find itself works.

I was wondering (since new users might not know this), if when a "\" is in a xml file, and the dev selects "GUI xml scripts" that the Find function would be able to check both forward and backward slash values, in order to show possible matches rather than "none found"?
Logged
Lead scripter for EO, Repop helper.
HSL Video tutorials:
https://community.heroengine.com/forums/index.php/topic,1719.msg36858.html#msg3685