HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [Resolved] Needing help with Facegen  (Read 1533 times)

Amarak

  • General Accounts
  • *
  • Posts: 281
    • View Profile
[Resolved] Needing help with Facegen
« on: Mar 08, 16, 11:52:27 PM »

I have spent 25-30 hours trying to follow the Facegen pipeline, but have met with negative results. I've tried following the Facegen Pipeline and the Facegen Tutorial from the Wiki, and Stadi's Facegen tutorial as well. I'm trying to start with just a few simple morphs for now.

I keep getting an error about the mesh and egm vertices not being the same amount, and I have tried exporting from Max both in HGM and OBJ formats. I used the same mesh from my Dynamic Character for my morph targets, so all the vertices should be the same, if that even makes a difference.

It may be something I am doing in the Customizer, there's little documentation about that part.

If anyone has any ideas...

:)
« Last Edit: Mar 10, 16, 09:16:02 PM by Amarak »
Logged

Thazager

  • General Accounts
  • *
  • Posts: 1155
  • Never stop learning
    • View Profile
    • Heroes and Villains MMORPG
Re: Needing help with Facegen
« Reply #1 on: Mar 09, 16, 10:37:36 AM »

We have tried doing also, but were not able to get it working yet. I have been able to get code (here) working with the original model (female ranger/wizard), but not any of our new models.
Logged

Amarak

  • General Accounts
  • *
  • Posts: 281
    • View Profile
Re: Needing help with Facegen
« Reply #2 on: Mar 09, 16, 04:43:44 PM »

I think the problem may be in the usage of the Customizer. If not that, then the HGM2OBJ. I can export a model from Max, then move a few vertices to make a morph target, and after using HGM2OBJ it seems to have a different number of vertices.

But like I said, it may just be a simple problem with not using the Facegen Customizer properly. I'll keep working on it but hopefully someone can make a quick walk through on the Customizer part of it.
Logged

Amarak

  • General Accounts
  • *
  • Posts: 281
    • View Profile
Re: Needing help with Facegen
« Reply #3 on: Mar 10, 16, 09:15:44 PM »

I got my Facegen to work. :)
It was as I suspected a matter of setting up the Customizer properly.
Logged