HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: SYSTEM:firestorm:Got a fatal error  (Read 1900 times)

Thazager

  • General Accounts
  • *
  • Posts: 1160
  • Never stop learning
    • View Profile
SYSTEM:firestorm:Got a fatal error
« on: Jun 01, 16, 10:41:57 PM »

Is this something to worry about?   "SYSTEM:firestorm:Got a fatal error"

It was when I clicked save in the GUI editor.

Code: [Select]
22:38:02: SCRIPT:[GUIeditor]:XML sent to repository.
22:38:02: SYSTEM:firestorm:Got a fatal error: Attempt to remove a handle with an invalid tag (BrowserResourceHandle::deleteReference).
22:38:02: SYSTEM:firestorm:Got a fatal error: Attempt to remove a handle with an invalid tag (BrowserResourceHandle::deleteReference).
22:38:03: SCRIPT:[GUIeditor]:closeEditor
22:38:08: SYSTEM:System:Requested updated resource /guixml/tmp_buffs.xml version=0. result=1
22:38:08: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
22:38:08: SYSTEM:System:Requested updated resource /guixml/tmp_buffs.xml version=0. result=1
22:38:08: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
22:38:08: SYSTEM:System:Requested updated resource /guixml/tmp_buffs.xml version=0. result=1
22:38:08: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
22:38:08: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
22:38:09: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
22:38:09: SYSTEM:System:Got XML file /guixml/tmp_buffs.xml
Logged
Lead scripter for EO, Repop helper.
HSL Video tutorials:
https://community.heroengine.com/forums/index.php/topic,1719.msg36858.html#msg3685

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: SYSTEM:firestorm:Got a fatal error
« Reply #1 on: Jun 01, 16, 11:49:08 PM »

when i ran into that it was due to a global environment file if i remember correctly (been a long time).
I think i finally figured out it was due to deleting an environment file that other areas were dependant on, and for some reason still looked for it...

maybe in your case it was due to a gui control being removed that another control relied on....

is it still happening or was it just a one time thing?

Might just keep an eye on it.  and see if you can note when it happens.
(like possibly other than when closing/saving the GUI editor)
as it looks like your save went through okay.

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: SYSTEM:firestorm:Got a fatal error
« Reply #2 on: Jun 01, 16, 11:50:56 PM »

It may be entirely unrelated, but here was my episode with the same error:

https://community.heroengine.com/forums/index.php/topic,5013.msg28214.html#msg28214

Thazager

  • General Accounts
  • *
  • Posts: 1160
  • Never stop learning
    • View Profile
Re: SYSTEM:firestorm:Got a fatal error
« Reply #3 on: Jun 02, 16, 12:42:48 AM »

I have the target buffs set up referencing the buffs for a similar way of showing them on screen. When I saved buffs, I guess it updated the target buffs also?  (I don't believe it ever did that before.)
Logged
Lead scripter for EO, Repop helper.
HSL Video tutorials:
https://community.heroengine.com/forums/index.php/topic,1719.msg36858.html#msg3685