HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.
Pages: 1 [2]

Author Topic: Opening the "GUI editor" tab crashes HE Client  (Read 3087 times)

FI-ScottZ

  • General Accounts
  • *
  • Posts: 1405
    • View Profile
    • Forever Interactive, Inc.
Re: Opening the "GUI editor" tab crashes HE Client
« Reply #15 on: Nov 03, 16, 02:55:07 PM »

I wonder if some gui relies on a class that has bad parents.
Logged
Scott Zarnke
Lead Programmer, Visions of Zosimos
CTO, Forever Interactive, Inc.

nocake

  • General Accounts
  • *
  • Posts: 404
    • View Profile
    • BlightMMO
Re: Opening the "GUI editor" tab crashes HE Client
« Reply #16 on: Nov 03, 16, 04:18:28 PM »

I think that has more to do with how the GUI Editor Tab Loads the GUI XML list. What ever it does during that, as well when creating a new GUI from the HeroScript Editor.

Both invoke something that causes HE to instantly crash and not be caught by even the bug reporter.

You can invoke this on a newly installed client.

I do think it is something to do with a bad class or XML mark up though, just not that a GUI relies on it.

ToY-Krun

  • General Accounts
  • *
  • Posts: 677
  • Support Volunteer
    • View Profile
Re: Opening the "GUI editor" tab crashes HE Client
« Reply #17 on: Nov 03, 16, 09:51:14 PM »

Okay I resubmitted the files from the errors I posted, and those errors are gone.

However it still crashes.  I'll look a bit more.

Okay:

I uploaded a copy of the BaseScrollBars.xml from HJREf as one of your xmls was referenceing it (in the list I posted yesteday you can see where) 

I made a comment as to why, and deleted hte contents of shop.xml and resubmitted it to get rid of the error regarding the "sleekOptionButton" since that control doesnt exist as a class or gui control on the world.  you can copy over any needed classes etc and then just revert that xml back one version and be fine there.

I got the editor panel working, however, due to the problem, i've put it back as it was.

your guixml.lst file contains invalid xml file names etc.  I reverted that file back to its initial version and the gui panel etc worked just fine, however if you reverted that far back, you'd have to go through readding files you need that arent in there.  I tried reverting all the way back to spring 2015 and it too has the same issue so im not sure how far back the problem goes or what file name could be causing it.  anyway, you know the solution now, even if it could prove tedious :P

I have no way of knowing what files you are using/whats not used etc so you'd have to figure that out.

You can open the guixml.lst file in notepad++ to examine it.


Hope that helps some!

nocake

  • General Accounts
  • *
  • Posts: 404
    • View Profile
    • BlightMMO
Re: Opening the "GUI editor" tab crashes HE Client
« Reply #18 on: Nov 03, 16, 11:09:58 PM »

Thank you how ever I know this did not occur during 2015 so it must be something in one of the script that existed back then but has changed since.

Thanks for all the help I will try to track this down more when I have the time.
Pages: 1 [2]