HeroEngine Forums
Welcome, Guest. Please login or Register for HeroCloud Account.

Author Topic: [RESOLVED] Modified server script not found on the repository  (Read 190 times)

Bardaf01

  • General Accounts
  • *
  • Posts: 11
    • View Profile

Hello!  :D

I made the mistake of editing a "cleanengine" script with debug messages so that I understood the code.

I commented each line with my changes, so I could theoretically simply delete them, but I thought I could do a simple revert.

However, among the recently modified scripts (from last week until now), I do not see the one I'm looking for (in HE/systemGenerated/compiledScript). I have only one being referenced as created by "INITIAL-IMPORT" and it's the "Input_Command" script on the client side). The others are mine.

Please kindly illuminate my lantern. :)

EDIT: I added "RESOLVED" to the subject.

Thanks a lot!
Best regards.
« Last Edit: Jun 07, 17, 01:55:57 PM by Bardaf01 »
Logged

Thazager

  • General Accounts
  • *
  • Posts: 1093
  • Never stop learning
    • View Profile
    • Heroes and Villains MMORPG
Re: Modified server script not found on the repository
« Reply #1 on: Jun 07, 17, 01:03:02 PM »

There are back ups of all the scripts in the same directory. You will need Perforce P4Merge to access those files, it's a free download my Microsoft.

With your script open, click "windows" on the top of editor, then go to History. It will show all the older versions of the script. You can revert to any of those.
Logged
Heroes and Villains Lead programmer/scripter
Exile Online Lead programmer/scriptor

Bardaf01

  • General Accounts
  • *
  • Posts: 11
    • View Profile
Re: [RESOLVED] Modified server script not found on the repository
« Reply #2 on: Jun 07, 17, 01:57:43 PM »

Hello Thazager! :D


Great! That's exactly what I needed! ;D


Thank you very much! :)
Cordially.
Logged